android - Java "get{Object}" method naming convention -
which of following compliant java guidelines?
observable<list<account>> getaccounts(string userid); observable<list<account>> getaccountsforuser(string userid);
i don't want start debate, i'm looking document stating guidelines. don't think matters, i'm using previous snippet of code inside android project.
i'd if there 1 type of model has "accounts" use
observable<list<account>> getaccounts(string userid);
if there multiple models have accounts, makes sense define method in more detail using:
observable<list<account>> getaccountsforuser(string userid);
Comments
Post a Comment